Bug Report: Disable sitekiosk autostart

Reproduction

Rebot PC
Sitekiosk start
Black windows appear

Description

Hello we have a big problem
We enable autostart in our sitekioks machine but when it start and we connect with RDP on that machine we can only see a black screen and we cannot do nothing.
The escape conbination don't work
We try to rebot pc and to kill manually processes and to reset the autologon key in registri but we cannot succeded to fix the problem
How can we disable autostart and come back again in our windows desktop?

Answer: (12)

Re: Disable sitekiosk autostart 7/12/2021 4:17 PM
This kind of problem may occur when starting SiteKiosk in start once mode while you are connected via Windows Remote Desktop at that time. Windows RDP and SiteKiosk interfere with each other and SiteKiosk will not start in "Start once" mode. (you only see the Watchdog background when starting SiteKiosk in “Start once” mode).


The recommended solution is using the integrated RDP feature of SiteRemote or even another RDP solution.

Otherwise you can access the machine after SiteKiosk startup (tested again due to your message and it works).
e.g. login to the admin account (the Windows RDP feature is disabled for non-admin users by default) and when done reboot the machine.
If you enabled Windows RDP for the SiteKiosk user or if you use a domain account for starting SiteKiosk you only need to access the machine via RDP again after reboot and SiteKiosk startup.

Alternatively use the integrated RDP feature of SiteRemote to exit SiteKiosk and disable the auto start mode.
You can also use SiteRemote to send a job to close SiteKiosk or Logoff the Windows user (this will not disable the auto start mode but you can login to the Admin user and SiteKiosk will not start if you have used the default auto start).

In general, we recommend using SiteRemote for remote maintenance purposes. More information here: https://www.provisio.com/web/uk/products/kiosk-remote-management-siteremote
Re: Disable sitekiosk autostart 7/12/2021 4:49 PM
Thank you for answer.
We have the problem enabling the autostart mode using our corporate domain user account.

When it starts and we connect via microsoft RDP we see a black screen and nothing happens more.
Besides we upgrade to last version as you suggested in order to receive support for another problem but now we have a bad situation because the sitekiosk don't start at all.
Kind Regards
Nicola
Re: Disable sitekiosk autostart 7/12/2021 4:59 PM
Hello,

Then you may alter the following Registry value at the client machine :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Here, you will find the entry SHELL.
Delete the SiteKiosk entry and replace it with 'explorer.exe'.

Then logout the Windows user and login to the admin again.

When having access again you first should check the config in Start once locally on site before activating the auto start mode.

Otherwise I only know of 2 other specific cases where a problem may occur when starting SiteKiosk:

1. SiteKiosk was installed without the appropriate Microsoft Visual C++ redistributable (only happens if you use the MSI file instead of SiteKiosk9.exe)

2. If you have reactivated the Windows account "Administrator" (with the name Administrator) and start SiteKiosk in this account



If none of these cases apply there is maybe any other security tool installed (e.g. Antivirus) or domain/group policy set that prevents the startup of SiteKiosk.

Generally, there is no known issue with SiteKiosk on supported operating systems.

But it could happen that another security tool is installed (e.g. antivirus) or a domain policy is set that prevents SiteKiosk from being installed or started in shell replacement.
Please check
You may also create a separate OU for the kiosk systems where no policies apply and set them later (step by step).
Re: Disable sitekiosk autostart 7/13/2021 8:52 AM
Hello, thank you for answer.
I try to explain better the situation:

we have a corporate network and a corporate domain.
We have a lot of sitekiosk machine installed in corporate domain.
All of this machine are config to autostart sitekiosk with a domain user that is a normale user (not admin).
We use the internet explorer engine and the start page settings in all sitekiosk machine.

But starting from next year our company avoid the use of internet explorer browser and will remove it from all machine on the network.

So the first question is:
- how happens to our machine running sitekiosk with internet explore engine if we remove ie from machine?

Before know this answer we wanted to try the same config using chrome engire and startup page config.
With an older version of sitekiosk (i think 9.2) we encountered errors opening more windows in startpage.

So you suggest us to install last version of sitekiosk and try with it the same test.
We do this yesterday, we installed last sitekiosk version but when we set the autostart with the domain user, when the machine starts, we cannot see nothing except a blank screen.

I explain this better:

- we config sitekiosk
- we set the autostart whit our domain user (not an admin user)
- we restart windows
- after some minutes (2 or 3) we connect remote sitekiosk machine usgin microsoft RDP (we have not the siteremote to manage machines, we use RDP)
- we put credential to login in the machine
- we see the sitekiosk registration key screen
- we skip this because we are using a free trial version (no license for the new version)
- after 2 or 3 minute where ve see the withe sitekiosk window with vault we switch to a blank screen
- we can move the mouse but nothing happens
- we cannot close sitekiosk using the escape combination
- we restart machine but always sitekiosk start again in the same situation

We don't know what we have to do to fix this problem
We don't know how we can disable the autostart in this situation

I hope now the situation is clear for you and you can help us to find the solution.
We have about 25-30 sitekiosk machines.
Kind Regards
Re: Disable sitekiosk autostart 7/13/2021 9:26 AM
Have you (or the domain admin) possibly deactivated the Windows Print Spooler service on the computer (because of: https://msrc.microsoft.com/update-guide/vulnerability/CVE-2021-34527)?

Then it would be easiest to let this service start again so that SiteKiosk can start.
We have currently discovered that SiteKiosk does not start with Chrome browser skin if the print spooler has been deactivated (SiteKiosk starts with IE skin).
This will be fixed in the next SiteKiosk version (there is no release date, but planned in the next 3 weeks)
Meanwhile you should use "Option 2 - Disable inbound remote printing through Group Policy" instead, that can be set via (Group or Domain) policy:
https://msrc.microsoft.com/update-guide/vulnerability/CVE-2021-34527



Otherwise you should disable the auto login and shell replacement via registry settings to get access again.

To disable automatic logon to Windows, set the following Windows Registry value from 1 to 0.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\AutoAdminLogon


To disable the shell replacement (for all users) you will also have to alter the following Registry value:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Here, you will find the entry SHELL.
Please delete the SiteKiosk entry and replace it with 'explorer.exe'.


There are several ways to access the Registry of your SiteKiosk computer (e.g. access them via network from another machine in the domain).
Also see "Ways to edit the REGISTRY." here:
https://www.provisio.com/en-GB/CustomerSupportCenter/ArticleDetails.aspx?ArticleID=364

If you want to login the user locally with using the hardware keyboard after changing the registry and rebooting the machine you also need to disable the SiteKiosk keyboard lock which is still active.
Please see Case 3: https://www.provisio.com/en-GB/CustomerSupportCenter/ArticleDetails.aspx?ArticleID=364
Pages (3): [1] 2 3 Next »
My Account
Login
Search
Search